redis requires Ruby version >= 2.2.2

在做redis集群,安装redis-gem的时候出现该错误:

#gem install -l redis-4.0.0.gem
ERROR:  Error installing redis-4.0.0.gem:
redis requires Ruby version >= 2.2.2.

原来是因为CentOS7 yum库中ruby的版本支持到 2.0.0,可gem 安装redis需要最低是2.2.2。那么只能手动更新了。
解决步骤:

1、安装RVM

gpg2 --keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3
curl -L get.rvm.io | bash -s stable
source /usr/local/rvm/scripts/rvm

2、安装Ruby新版本

rvm install 2.3.3

3、设置默认使用新版本

rvm use 2.3.3 --default

4、卸载旧版本

rvm remove 2.0.0
打赏作者

《redis requires Ruby version >= 2.2.2》有1个想法

发表评论

电子邮件地址不会被公开。 必填项已用*标注